Микротик для чайников: мост точка и многоточка

Содержание
  1. Нужна настройка MikroTik в базовой конфигурации?
  2. Вход в настройки роутера MikroTik
  3. Установить пароль на роутер
  4. Обновление прошивки в MikroTik
  5. Настройка первой точки (Master)
  6. Настройка второй точки (Slave)
  7. Инициализация беспроводного моста
  8. Проверка интерфейсов маршрутизатора для настройки моста
  9. MAC-адресация
  10. Настройка Mikrotik Bridge
  11. Алгоритм создания mikrotik мост для трех портов
  12. Как проверить MAC-таблицу и увидеть процесс заполнения адресами?
  13. Сброс Mikrotik на заводские настройки
  14. Настройка в меню BRIDGE
  15. ШАГ 1: Создаем Virtual AP
  16. ШАГ 2: Настройка сетевого моста
  17. ШАГ 3: Настройка второго роутера
  18. ШАГ 4: Подключение роутеров
  19. Настройка в меню Wireless
  20. 1. Настройки на вкладке Wireless
  21. 2. Настройки на вкладке Data Rates
  22. 3. Настройки на вкладке Advanced
  23. 4. Настройки на вкладках HT, HT MCS, WDS
  24. 5. Настройки на вкладке NV2
  25. 6. Настройки на вкладке TX POWER
  26. Настройка шифрования
  27. Настройка второго устройства
  28. Просмотр показателей соединения
  29. Преамбула
  30. Настройка
  31. Настройка базовой станции
  32. Настройка клиентской точки
  33. Отличия точка-точка (P2P) и точка-многоточка (P2MP)
  34. Выбор устройства для беспроводного моста
  35. Установка на месте

Нужна настройка MikroTik в базовой конфигурации?

Настройка сервисов на маршрутизаторах MikroTik: подключение интернета, DHCP, brige, VLAN, WiFi, Capsman, VPN, IpSec, PPTP, L2TP, Mangle, NAT, проброс портов, маршрутизация(routing), удаленное подключение и объединение офисов.

Вход в настройки роутера MikroTik

Winbox эта утилита, которая обнаружит устройство независимо от назначенного ему адреса. Чаще всего это 192.168.88.1, но и встречаются варианты когда ip адрес = «0.0.0.0». В этом случае подключение происходит по MAC адресу устройства. Кроме этого Winbox отображается все найденные устройства MikroTik в сети, а также дополнительную информацию(версия прошивки, UpTime):

данные для подключения по умолчанию

  • пользователь = «admin»
  • пароль = «»(пустой)

Установить пароль на роутер

Первым важным делом настройки нового роутера это обновление пароля администратора. Случаи бывали разные, это пункт просто нужно выполнить.

Настройка находится в System->Users

добавление нового пользователя с полными правами:

/user add name="admin-2" password="PASSWORD" group=full

деактивация старого пользователя:

/user set [find name="admin-2"] disable="yes"

Обновление прошивки в MikroTik

Одной из важной задачей при вводе в эксплуатацию нового устройства MikroTik: маршрутизатора(роутера), коммутатора(свчитча) или точки доступа WiFi это обновление прошивки. Чаще всего это имело рекомендованный характер, но недавний инцидент с “back door” в категории long-term указал но то, что актуальность прошивки на устройствах MikroTik имеет критический характер.

Настройка находится в System->Packages

Настройка первой точки (Master)

Перед началом настройки, необходимо установить либо закрепить SXT на штативе или в любом другом месте, так, чтобы его не требовалось держать в руках. Чем больше расстояние между двумя устройствами – тем лучше.

В качестве главного устройства (Master), у нас будет выступать SXT Lite 5 ac. Второй SXT мы включим чуть позже.

При первом включении SXT Lite 5 ac можно использовать настройки по-умолчанию (Default), при необходимости, сбросить настройки можно через меню System – Reset Configuration.

Первым делом меняем режим работы на PTP Bridge. Делается это в выпадающем меню на странице QuickSet.

Второй этап – установка режима Bridge (мост) и задание статического адреса устройству. В нашем случае мы указываем статический IP 192.168.106.150, а также DNS-сервер и шлюз нашей локальной сети (IP 192.168.106.1). Мы настоятельно рекомендуем использовать именно статический адрес, в противном случае IP вашего устройства будет меняться (конфигурация Automatic / DHCP), если вы не сделаете привязку MAC:IP в настройках сервера DHCP.

В режиме PTP Bridge выбираем Wireless Mode – Server/AP, т.е. указываем, что наш SXT будет работать в качестве точки доступа (Master), к которой будет подключено второе устройство (Slave).

Как видите, в QuickSet для SXT Lite 5 ac, по-умолчанию, доступна служебная подсеть 2.4 ГГц, в связи с чем, дальнейшую настройку мы будем выполнять в других разделах.

В разделе Wireless, при необходимости, отключаем сеть 2,4 ГГц – интерфейс wlan1 (AR9300). Не спешите включать интерфейс на 5 ГГц (wlan2-gateway, AR9888), поскольку он работает при высокой мощности, которую следует понизить при использовании в помещении.

Выбираем наш интерфейс и в правой части нажимаем «Advanced Mode» (расширенный режим), после чего нам станут доступны расширенные настройки. Переходим во вкладку TX Power, выбираем режим «all rates fixed» и устанавливаем мощность на уровне 2 дБм.

Пониженная мощность необходима для того, чтобы устройства не глушили друг друга, к тому же не рекомендуется находиться в непосредственной близости с устройствами со столь мощным уровнем излучением. Если следовать рекомендациям, на расстоянии 1 метра от устройства, уровень сигнала не должен превышать -20 дБм.

Следующим этапом является выбор рабочего канала (частоты). Выбирать следует ту частоту, на которую вам выдано разрешение.

Предварительно можно просканировать эфир на предмет загруженности частот. Делается это с помощью инструмента Freq. Usage (Frequency Usage). Выбираем беспроводной интерфейс и нажимаем Start.

Как видите, часть частот уже используется. Для получения более подробной информации можно воспользоваться другим инструментом – Scan, который покажет все доступные беспроводные сети. Здесь вы можете посмотреть название сети, рабочий канал, уровень сигнала и другие параметры. Много информации можно узнать из индексов, находящихся перед названием сети:

  • A – сеть активна;
  • R – устройство на базе RouterOS;
  • T – используется TDMA;
  • W – сеть использует WDS;
  • B – режим моста, Bridge:
  • P – приватная сеть, защищена паролем;

Для сети 2.4 ГГц также можно провести сканирование, вы будете удивлены результатами, проводя сканирование в городе. Именно поэтому частота 5 ГГц лучше подходит для построения беспроводного моста. Для нашего примера мы выбрали частоту 5745 МГц из верхнего диапазона, т.к. этот диапазон менее загружен, к тому на практике он дает лучшую производительность в расчете на 1 МГц ширины канала.

Приступаем к конфигурированию беспроводной сети, на вкладке Wireless необходимо указать ряд параметров. Чуть ниже содержится описание и разъяснение.

Mode: Bridge – режим работы «Беспроводной мост».

Band – в данном параметре следует можно выбрать стандарт 802.11n. При использовании протокола Nstreme V2 (NV2) данный параметр большого значения не имеет. В остальных случаях рекомендуем использовать 802.11n, либо 802.11ac, если он поддерживается обоими устройствами.

Channel With – ширина канала, а также направление для расширения канала по отношения к выбранной частоте (Ce – вверх, eC — вниз). Указываем «20/40MHz Ce», это значит, что система попробует работать с шириной канала 40 МГц, в противном случае ширина канала будет 20 МГц. Расширение ширины канала осуществляется вверх, выбирая последний канал (частоту), следует выбирать режим расширения «eC», в противном случае, при достижении верхнего предела поддерживаемой частоты канал не будет расширен.

Frequency – частота, на которой работает устройство.

Wireless Protocol – протокол (стандарт) связи. Поскольку только одно из наших устройств поддерживает новейший стандарт 802.11ac, наилучшим вариантом будет выбор проприетарного протокола NV2.

Следующим шагом необходимо проверить вкладку HT, убедитесь, что у вас задействованы оба канала MIMO – напротив TX Chain и RX Chains должны быть проставлены по 2 опции (chain0, chain1).

Далее переходим на вкладку WDS. И тут у многих возникает вопрос, зачем активировать WDS? Дело в том, что стандарты связи 802.11 разрабатывались достаточно давно, поэтому для AP предусматривалось, что подключенный клиент является конечный. По этой причине для точки доступа все MAC за второй точкой (в режиме station) будут подменяться на MAC самой точки доступа. Чтобы этого не происходило, необходимо активировать WDS. Таким образом, мы создаем прозрачный мост L2 с сохранением MAC всех клиентов.

Необходимо указать параметр «WDS Default Bridge» – выбираем мост, в нашем случае используются настройки по-умолчанию, так что это будет «bridge-local».

Переходим на вкладку NV2, где собраны параметры протокола Nstreme V2.

TDMA Period Size – параметр, устанавливающий размер слота. Иными словами это временной период, в котором осуществляется передача данных. Параметр может применять значение от 1 до 10. Чем меньше размер слота, тем меньше задержка при передаче, но ниже максимальная скорость (больше служебных данных в эфире) и наоборот. Для беспроводного моста наиболее оптимальным вариантом будет установить 2 мс. В дальнейшем с этим параметром можно поэкспериментировать.

Cell Radius – расстояние до второго устройства в километрах. Минимальное значение – 10 км, если реальное расстояние меньше – оставляем параметр без изменений. Если расстояние больше, его следует указать с небольшим запасом.

Ставим опцию «Security» и вводим пароль в поле «Preshared Key».

Если вы используете стандартные протоколы 802.11, пароль и тип шифрования следует задавать в разделе Wireless, вкладка Security Profiles. Всегда выбирайте наиболее современные стандарты (WPA2 PSK + aes ccm).

Для беспроводных мостов, использующих большую часть полосы пропускания, рекомендуется установить дополнительные параметры очереди. Связано это с тем, что часть пакетов может быть отброшена, чтобы этого не происходило, следует увеличить размер буфера.

Для этого заходим в раздел меню Queues и переходим на вкладку Queue Types (типы очередей).

Здесь нас интересуют типы «ethernet-default» и «wireless-default», для обеих нужно выбрать тип очереди PFIFO и значение Kind = 500.

PFIFO – тип очереди, основанный на принципе «First-In First-Out»: пакет, который пришел первым будет отправляться первым, т.е. по сути обычная очередь. Разница между методами PFIFO и BFIFO состоит в том, что первый метод в качестве параметра использует количество пакетов, а второй оперирует размером буфера.

Буфер можно установить в размере 500 пакетов, в дальнейшем мы рекомендует подправить этот параметр. Если на мосте увеличивается пинг – размер буфера следует уменьшать до достижения приемлемого значения.

На этом настройка SXT Lite 5 ac (Master) завершена, переходим к настройке второго устройства.

Настройка второй точки (Slave)

Для второй точки также устанавливаем режим PTP Bridge, а в нем режим Client/CPE. Общий режим устройства – Bridge.

Для устройства задаем статический IP (в нашем случае 192.168.106.200) и настраиваем параметры сети (маска, шлюз, DNS).

Перед настройкой отключаем беспроводной интерфейс, и устанавливаем для него минимальную мощность.

Если вы используете протокол 802.11, тип шифрования и пароль следует предварительно задать в профиле, вкладка Security Profiles раздела Wireless. Теперь можно приступить настройке беспроводного интерфейса.

Выбираем интерфейс и переходим на вкладку Wireless. Устанавливаем режим «station wds», по сути, это клиентская станция-репитер, только сеть она расширяет по проводам, а не по Wi-Fi.

Ширину канала (Channel Width), частоту (Frequency), протокол (Wireless Protocol) и SSID указываем аналогично тем, что установлены на первом устройстве (Master).

На вкладке HT убедитесь, что у вас активированы оба канала.

На вкладке WDS выбираем режим «dynamic» и указываем наш бридж с локальным интерфейсом.

На вкладке NV2 установите опцию «Security» и введите пароль сети.

Не забудьте увеличить размер очереди в меню Queues.

Инициализация беспроводного моста

После того, как параметры на обоих устройствах установлены, можно включить беспроводные интерфейсы на обоих устройствах.

Если все проделано верно, на Slave-устройстве должны отобразится параметры моста и статус «connected to ess».

Для проверки работоспособности моста можно прогнать его с помощью тестов.

Как видите, с помощью протокола NV2 нам удалось добиться достаточно высокой скорости на сетевых интерфейсах – суммарно 180-190 Мбит/сек, т.е. по 95 Мбит в каждую сторону (полный дуплекс). Реальная скорость передачи данных в этом случае составляет ~170 Мбит/сек.

Проверка интерфейсов маршрутизатора для настройки моста

Убедитесь, что ваше устройство имеет более одного интерфейса.
Mikrotik Routerboard выглядит как коммутатор, для чего нам нужно делать мост? Мы можем просто подключить кабель, и он будет работать как обычный switch?

MAC-адресация

Знаете ли вы, что на каждом интерфейсе вашего маршрутизатора есть MAC-адрес, назначенный ему? Да, на каждом порту / интерфейсе. Почему на каждом порту? Поскольку Mikrotik Routerboard — это в основном маршрутизатор, который объединяет сети. Каждый интерфейс роутера подключен к сети, и каждый интерфейс в сети выступает в качестве шлюза для клиентов в сети. Поэтому для каждого интерфейса требуется IP-адрес (layer3), и, на более низком канальном уровне им нужна адресация 2 уровня.

Настройка Mikrotik Bridge

Поскольку основная наша цель — создать сеть второго уровня модели OSI (сеть с коммутатором), то нам необходимо настроить функцию моста. Благодаря функции моста (mikrotik bridge) можно объединить несколько портов в один сегмент. Поэтому все порты, которые объединяются интерфейсом моста, станут плоскими, аналогично простому коммутатору.

Алгоритм создания mikrotik мост для трех портов

Создадим новый интерфейс мост на mikrotik (этот интерфейс станет основным интерфейсом). Скажем, мы создаем мост с именем bridge1:

/ interface bridge add name = bridge1 disabled = no protocol-mode = rstp

Поместить порты (интерфейсы) в мост (эти интерфейсы станут подчиненными интерфейсами). Теперь эти интерфейсы называются портами, как на обычном коммутаторе. Пример: ether1-ether3 будут помещены в bridge1:

/interface bridge port add bridge=bridge1 interface=ether1
/interface bridge port add bridge=bridge1 interface=ether2
/interface bridge port add bridge=bridge1 interface=ether3

Мост – это гибкая функция, мы можем поместить другие технологии layer2 в мост (эти интерфейсы также станут подчиненными интерфейсами). Например, wifi:

/interface bridge port add bridge=bridge1 interface=wlan1

Что происходит с MAC-адресом на интерфейсах, которые объединены с мостом? Так как мост является устройством 2 уровня, MAC-адрес на каждом интерфейсе будет проигнорирован

Как проверить MAC-таблицу и увидеть процесс заполнения адресами?

Вы можете увидеть список на вкладке хоста в меню моста или вы можете отобразить таблицу с помощью mikrotik CLI:

/ interface bridge host print

Сброс Mikrotik на заводские настройки

1. Если вы подключились к устройству первый раз, то соответствующее окно с заголовком RouterOS Default Configuration появится сразу при входе, для сброса настроек нужно нажать на кнопку Remove Configuration.

2. Если на устройство уже заходили, то такое окно по умолчанию не появляется. Заходим в меню New Terminal и с помощью команды system reset-configuration перезагружаем устройство (после перезагрузки появляется окно сброса настроек).

Или же идем в меню System, потом — в Reset Configuration. В окне выставляем галочку в пункте No Default Configuration и жмем на Reset Configuration.

Заводская конфигурация сброшена, начинаем настраивать.

Настройка в меню BRIDGE

Добавляем порты, чтобы проходящий через оборудование MikroTik трафик мог передаваться дальше по проводному и WiFi интерфейсу. Иначе наши устройства будут «общаться» только между собой.

Для этого в меню Bridge жмем на кнопку + (открывается окно как на картинке ниже), присваиваем бриджу имя и жмем Ок.

Переходим на вкладку Ports, нажимаем на + и добавляем порт Wlan1 в строке Interface. В строке Bridge выбираем ранее созданный нами bridge1. Жмем Ок.

Опять нажимаем на + и создаем уже порт Ether1:

Присваиваем IP-адрес бриджу:

Меню IP => подменю Adresses => кнопка «+», вписываем адрес бриджа и через слэш — маску подсети. Поле Network заполнять необязательно.

ШАГ 1: Создаем Virtual AP

И так у нас есть основной роутер, на котором на каждый порт идет отдельная сеть

ether2 192.168.2.0/24
ether3 192.168.3.0/24
ether4 192.168.4.0/24
ether5 192.168.5.0/24
wlan0 192.168.10.0/24

Настройка будет происходить через Web-интерфейс. Подкачаемся к аппарату, заходим внутрь и далее переходим «Wireless» – «Security Profiles». Нажимаем на кнопку добавления нового профиля. Создаем профиль, именно на первом интернет-роутере. Так как сеть у нас будет связана с гостиной, то и назвал её так как на картинке ниже.

Теперь надо создать наш Virtual AP: «Wireless» – «Interfaces» – «Add New» – «VirtualAP». Не забудьте указать профиль, который создали выше (Security Profile). А теперь вспоминаем нашу картинку, там связь со вторым маршрутизатором идёт через «wlan»1 – его нужно указать в строке «Master Interface».

ШАГ 2: Настройка сетевого моста

Нам необходимо соединить два подключения «ether3» и «gostinnaya». Первое подключение как мы помним имеет доступ к NAS. А второе подключение в будущем будет закреплено за вторым роутером. Как мы и хотим, нужно чтобы второй роутер имел доступ к NAS.

Переходим в «Bridge» и добавляем новый мост. Можете назвать мост как угодно.

Виртуальный мост теперь надо связать по портам. Для этого в «Bridge» – «Ports» и добавляем новое правило. Теперь добавляем интерфейсы: «ether3» и то, которое мы создали ранее.

Ура мы настроили первый аппарат, теперь осталось настроить второй и работа почти завершена.

ШАГ 3: Настройка второго роутера

Данный аппарат уже настроен так, чтобы все Wi-Fi подключения, а также интернет-порты WLAN имели одну и туже подсеть – то есть третью 192.168.3.0/24. Ещё необходимо сделать пару моментов до настроек:

  1. «IP» – «Firewall» -«NAT» – выключите правило;

  1. «IP» – «DHCP Server» – «DHCP» – далее нужно выключить стандартное правило DHCP;

  1. Теперь нам необходимо сделать так, чтобы IP мы получали от первого роутера. «IP» – «DHCP Client» – «DHCP Client». Далее добавляем интерфейс сетевого моста.
  2. Также у нас есть ещё одна проблемка, наш «Ether1» нужно добавить в сетевом мост, который будет связывать с последним компьютером (смотрим на картинку). «Interfaces», теперь выбираем наш интернет интерфейс и в «Master Port» необходимо выбрать «ether2» локальный порт.

ШАГ 4: Подключение роутеров

«Wireless» – «Security Profiles» – тут все делается аналогично, как и с первым аппаратом. Далее переходим «Wireless» – «Interfaces» и настраиваем уже беспроводной интерфейс.

Теперь переходим в «Bridge» и выбираем раздел «Ports». И добавляем новый порт. Не забываем указать новое подключение, которое мы создали выше. В данном случае на картинке выше под именем «wlan1».

Ещё один момент зайдите в настройки «wlan1» и там нужно поменять мод. Лучше установить «Station bridge» или «Station pseudobridge» – принципе разницы нет можете выбрать любой. Без этого работать не будет.

Настройка в меню Wireless

Выбираем пункт меню Wireless, открываем Wlan1.

1. Настройки на вкладке Wireless

Здесь настраиваются параметры беспроводного интерфейса:

Параметр Описание Варианты значений
Mode Режим работы

Сейчас нас интересуют:

Bridge – режим БС для соединения точка-точка
AP Bridge – режим БС для соединения точка-многоточка.

Также здесь есть режимы для клиентских станций:

Station – режим для клиентского устройства.
Station WDS – режим для клиентского устройства с поддержкой WDS. Рекомендуется использовать на клиенте именно его.

Band Частота работы устройства и поддерживаемые стандарты.

Первая часть значения, до тире — это частота работы, вторая — поддерживаемые стандарты. Для стандартов рекомендуется выбирать значение only-N, чтобы поднять максимальную скорость.

На клиентском устройстве можно выбрать несколько вариантов стандартов, к примеру, выставить 2GHz-B/G/N, тогда при изменении настройки на БС клиенты переподключатся автоматически.

Channel Width Ширина канала.

Стандартно ставится 20мгц. Если планируется более 100 Мбит/сек и используется гигабитное устройство — тогда можно использовать полосу 40мгц.

Frequency Частота, на которой будет работать устройство.

Выбирается из списка или прописывается вручную.

SSID

Имя сети. Именно его будут видеть абонентские устройства.

Radio Name

Имя устройства. Используется чаще всего для станций на стороне абонентов — с целью их последующей идентификации на базовой станции.

К примеру, kv_Titova_d_8.
Scan List Частотный диапазон. Выставляется на стороне клиента, ограничивая тем самым список частот, в которых устройство будет связываться с БС.

По умолчанию — default, при этом используются только стандартные каналы. Можно указать одну частоту, несколько (разделив запятой), диапазон (через тире), а также можно совместить. К примеру, значение «2424, 2300-2500» будет означать что устройство сначала начнет поиск БС на канале 2424, при отсутствии ответа перейдет на диапазон 2300-2500 и будет искать на нем.

Wireless Protocol Протоколы работы оборудования.

802.11 – обычный протокол wi-fi, подходит для подключения к базовой станций клиентов с ноутбуками или USB адаптерами.

Nstreme – старый поллинговый протокол. Если он выставлен в настройках, к БС смогут подключиться только устройства, которые его поддерживают. С помощью ноута или юсб-адаптера подключиться нельзя.

NV2 – последний фирменный поллинговый протокол Микротик. Используем его. Опять же, соединение будет доступно для устройств, которые поддерживают данный вид протокола. С помощью ноута или юсб-адаптера подключиться нельзя.

Any – это режим выставляется у абонентов. Таким образом обеспечивается соединение с БС при любых выставленных на ней режимах.

Security Profile

Выбор способа шифрования.

Обычно — default.
Frequency Mode

Режим выбора доступных частот и мощностей

Manual Txpower – этот режим предусматривает возможность ручного изменения настроек мощности радиосигнала.

Regulatory Domain – выбор режима работы с параметрами мощности и частот, разрешенных для определенной страны.

Superchannel – в этом режиме можно изменять мощность, а также использовать все доступные частоты.

Counrty Выбор страны для определения списка частот, которые в ней доступны.
Antenna Gain

Ограничение мощности устройства.

Чаще всего не используется, в поле выставляется значение «0».
WMM Support Приоритеты радиоканала.
Bridge Mode Включение/выключение режима «bridg» на радиокарте. Всегда — enabled.
Default Authenticate

Разрешение подключений.

При выставленной галочке — могут подключаться все устройства, при снятой — только те, которые есть в списке разрешенных.

Default Forward

Выставленная галочка — запрет обмена данными между подключенными клиентскими устройствами. Эта настройка работает только в режиме 802.11 для ноутбуков и устройств без поддержки WDS.

Hide SSID

Выставленная галочка скрывает имя сети ( сеть не появляется в списке при сканировании). Чтобы подключиться, нужно вручную прописать имя на устройстве клиента.

2. Настройки на вкладке Data Rates

В случае если мы выбираем для устройств режим N-only, то все галочки на этой вкладке снимаются. Иначе — смотрим параметры настройки ниже.

Параметр Описание Варианты значений
Rate Selection Выбор модуляций

Ставим Advanced для самостоятельного определения наилучшей модуляции устройствами.

Supported Rates B Разрешенные модуляции для стандарта B. Галочки снимаем, чтобы устройства использовали только более скоростные стандарты G и N.
Supported Rates A/G

Разрешенные модуляции для стандартов A и G.

Здесь проставляем все галочки.
Basic Rates B

Разрешенные модуляции для служебного трафика.

Все галочки снимаем.
Basic Rates A/G

Разрешенные модуляции для служебного трафика.

Устанавливаем только 6 М.

3. Настройки на вкладке Advanced

Параметр Описание Варианты значений
Max Station Count Максимальное количество клиентских подключений
Distance Максимальное расстояние до станций абонентов

Dynamic — расстояние определяется автоматически.

Indoor — это значение выставляем для передачи данных внутри помещений.

Noise Floor Threshold Ручная корректировка уровня шума на канале.

Чаще всего ставятся значения -92 … -107. Можно также определить его самостоятельно: замерить уровень шума и уменьшить эту цифру на 5-10 единиц. К примеру: фактический уровень шума -107, следовательно, значение выставляем -100.

Periodic Calibration Автоматическая корректировка шума на канале. Рекомендуется всегда включать этот параметр (enabled), так устройство будет автоматически подстраиваться под повышение/понижение уровня помех.
Calibration Interval

Промежутки времени, через которые устройство будет определять уровень помех.

Рекомендуется выставлять 10 сек. Дефолтно стоит 1 минута.
Hw. Retries Количество повторов отправки данных, если не приходит подтверждение получения.

Значения от 1 до 5 — скорость работы сети выше, однако для абонентов с плохим сигналом стабильность связи ухудшится (потеря пакетов, частый дисконнект).

Значения от 5 до 10 — золотая середина.

Значения от 10 до 15 — максимальная гарантия доставки данных, но в проблемной сети скорость будет замедляться.

Исходя из этого, для базовой станции предпочтительно выставлять средние значения (5-7), а для канала точка-точка ставится максимум — 15.

Hw. Protection Mode

Включает защиту от скрытого узла.

Всегда выставляем RTS/CTS.
Adaptive Noise Immunity Фильтрация помех средствами радиокарты. Рекомендуется активировать параметр AP and client mode для защиты от помех, если рядом находятся несколько базовых станций.
Disconnect Timeout

Временной промежуток, через который клиент, не отвечающий на запросы, будет отключен.

On Fail Retry Time Время ожидания устройства перед повторной пересылкой данных. Рекомендуется оставлять 100 мс.

4. Настройки на вкладках HT, HT MCS, WDS

Если наши устройства используют MIMO (что желательно, так как пропускная способность такого оборудования выше), то нужно уделить внимание соответствующим настройкам антенн на вкладке HT:

  • HT Tx Chains — канал приема, HT Rx Chains — канал передачи. Если используется MIMO, лучше всего активировать обе антенны и на прием, и на передачу (chain0, chain1). Разумеется, если антенна только одна, то активируем один канал.
  • В параметре HT Guard Interval ВСЕГДА выставляем long, если используется стандарт N для наружных линков.
  • HT Extension Channel — этот параметр предназначен для добавления дополнительных каналов при использовании полосы в 40 мгц. Оптимальные значения устанавливаются экспериментально.


На вкладке HT MCS рекомендуется оставить значения по умолчанию.

На вкладке WDS нас интересуют 2 параметра:

  • WDS Mode — рекомендуется выставлять режим Dynamic, тогда новые клиенты в бридж будут добавляться автоматически. В случае предпочтения ручного добавления выбираем Static.
  • WDS Default Bridge — дефолтно клиенты будут добавляться в указанный в этом поле бридж. Поэтому указываем здесь его наименование: bridge1.

5. Настройки на вкладке NV2

Здесь мы настраиваем параметры микротиковского протокола NV2 (кстати, настройки протокола NSTREME и соответствующую вкладку не рассматриваем именно потому что он устарел и практически не применяется).

  • TDMA Period Size — время передачи. Для базовой станции рекомендовано выставлять 5-7, для радиомоста — 1-2. Чем меньше значение в этом поле, тем меньше задержки при передаче, но падает скорость. И наоборот — большее значение будет означать большую скорость, но и увеличенные задержки. Оптимальное значение подбирается путем экспериментов.
  • Cell Radius — здесь мы выставляем расстояние до самого удаленного клиента
  • Security — включаем/выключаем протокол шифрования по протоколу NV2. Это совершенно отдельный механизм шифрования, не имеющий отношения к тому, что мы будем настраивать на вкладке Security Profiles.
  • Preshared Key — защитный ключ для подключения к сети, на всех устройствах ставим одинаковый.

6. Настройки на вкладке TX POWER

Чаще всего оставляется значение Default. Если выбрать Manual, то разворачиваются поля с настройками и можно вручную корректировать параметры мощности радиокарты.

Настройка шифрования

В разделе Wireless идем на вкладку Security Profiles:

  • Name — присваиваем имя профилю шифрования.
  • Mode — выбор режима шифрования, чаще всего ставим Dynamic Keys.
  • Authentication Types — ставим галочки либо в WPA PSK, либо в WPA2 PSK, или же выбираем оба.
  • Unicast Ciphers — выбор алгоритма шифрования. Рекомендован AES, т.к. его поддерживает радиокарта.
  • Group Ciphers — такие же настройки как в предыдущем пункте.
  • WPA Pre-Shared Key — кодовое слово для шифрования типа WPA. Ставим одинаковое на всех устройствах
  • WPA2 Pre-Shared Key — аналогично, пароль для типа шифрования WPA2

Настройка второго устройства

Большинство настроек идентичны, за исключением:

  • При настройке IP-адреса второй точки делаем его отличающимся от адреса первой.
  • При настройке параметров беспроводного интерфейса на вкладке Wireless указываем: в поле Modestation wds, в поле SSID — имя первой точки.

Просмотр показателей соединения

Если мы все настроили правильно, то на вкладке Status беспроводного интерфейса можно посмотреть параметры:

Параметр Описание
Band Частота и стандарт работы точки (режим)
Frequency Канальная частота работы устройства
Tx/Rx Rate Модуляции приема и передачи
SSID Название сети
BSSID Мак-адрес второго устройства
Radio Name Имя второго устройства
Tx/Rx Signal Strenght Уровень сигнала приема/передачи. Если используются две антенны, данные суммируются.
Tx/Rx Signal Strenght Ch0 Уровень сигнала приема/передачи на нулевой антенне (канале)
Tx/Rx Signal Strenght Ch1 Уровень сигнала приема/передачи на первой антенне (канале)
Noise Floor Уровень шума
Signal To Noise Соотношение сигнала к шуму. Стандартно считается, что значения от 5 до 15 — низкие, от 15 до 30 — средние, от 30 до 60 — высокие. Чем больше значение в этом поле — тем лучше.
Tx/Rx CCQ

Качество канала приема/передачи.

От 1 до 50 — плохо

От 50-80 — средне

От 80-100 — хорошо.

Distance Дистанция до второго устройства
Router OS Version Версия прошивки второго устройства
Last IP Последний IP-адрес, зафиксированный в устройстве
WDS Link Показывает работу в WDS.

Преамбула

В результате падения дерева была оборвана линия связи между заводскими цехами. В результате аварии без связи остался один цех (интернет, IP-телефония) и пропал доступ к нескольким камерам видеонаблюдения.

В качестве временного решения был поднят радиомост из того что было под рукой (TP-Link). Одновременно были заказаны микротики.

И вот они пришли, приступаем к настройке.

Настройка

В первую очередь обновляем версию RouterOS до актуальной и сбрасываем все настройки. Как это делать описывать не буду, если кто не знает можете прочитать в одной и моих предыдущих записей.

Так же не буду описывать как сменить пароль администратора и тому подобные базовые вещи, приступим сразу к настройке радиомоста и начнём с точки, которая будет выполнять функции базовой станции (BS).

Все настройки рекомендую производить в своём кабинете и на место уже устанавливать полностью настроенными.

Настройка базовой станции

  • Создаём бридж и добавляем в него все интерфейсы (ether1 и wlan1)
/interface bridge add name=bridge1 /interface bridge port add bridge=bridge1 interface=wlan1 add bridge=bridge1 interface=ether1
  • Присваиваем бриджу IP-адрес
Присваиваем IP-адрес
/ip address add address=192.168.88.116/24 interface=bridge1 network=192.168.88.0
  • Переходим в настройки Wireless и создаём Security Profiles
Security Profiles
/interface wireless security-profiles set [ find default=yes ] supplicant-identity=MikroTik add authentication-types=wpa2-psk disable-pmkid=yes eap-methods="" management-protection=allowed mode=dynamic-keys  name=xxxxx supplicant-identity="" wpa2-pre-shared-key=QqAaZzWwSsXx
  • Настраиваем интерфейс wlan1

Изначально Wireless Protocol я настраиваю как nv2 nstreme 802.11, затем после установки на месте я на базовой станции переключаюсь между nv2 и 802.11 и смотрю какой из них лучше себя ведёт в плане скорости и устойчивости. Если 802.11 показывает себя быстрее, то оставляю его и наблюдаю в течении некоторого времени на предмет срабатывания DFS (Dynamic Frequency Selection). Если в логах появляется запись вроде такой

wlan1: radar detected on 5260000

то переключаю BS на nv2 и забываю об этой проблеме.

Ещё один момент на который стоит обратить внимание. При работе по протоколу nv2, Security Profiles не используется. На вкладке с настройкой NV2 устанавливается свой PSK.

Antenna Gain берём из документации на устройство на сайте MikroTik. Вообще данный параметр указывает на сколько нужно понизить выдаваемую мощность передатчика, которая компенсируется коэффициентом усиления антенны что бы не нарушать законодательство страны.

Band, Channel Width и Frequency выбираем по радиообстановке на месте.

Mode для базовой станции устанавливаем ap bridge.

/interface wireless set [ find default-name=wlan1 ] adaptive-noise-immunity=ap-and-client-mode antenna-gain=16 band=5ghz-onlyac  channel-width=20/40/80mhz-Ceee disabled=no frequency=5260 hw-protection-mode=rts-cts installation=outdoor  mode=ap-bridge multicast-helper=full nv2-cell-radius=10 nv2-preshared-key=xxxxx nv2-qos= frame-priority nv2-security=enabled security-profile=xxxxx ssid=XXXXX wireless-protocol=nv2-nstreme-802.11  wmm-support=enabled wps-mode=disabled

Настройка клиентской точки

Настройка клиентской точки по сути ничем не отличается от настройки базовой станции кроме двух пунктов.

В настройках wlan1 Mode выбираем station bridge и Adaptive Noise Immunity выбираем client mode.

/interface wireless set [ find default-name=wlan1 ] adaptive-noise-immunity=client-mode antenna-gain=16 band=5ghz-onlyac  channel-width=20/40/80mhz-Ceee disabled=no frequency=5260 hw-protection-mode=rts-cts installation=outdoor  mode=station-bridge multicast-helper=full nv2-preshared-key=xxxxxxxx nv2-security=enabled  security-profile=xxxxx ssid=XXXXX wireless-protocol=nv2-nstreme-802.11 wmm-support=enabled

Отличия точка-точка (P2P) и точка-многоточка (P2MP)

С точки зрения настроек отличие только одно – на базовой станции Mode устанавливается или bridge или ap bridge.

В первом случае работаем точка-точка, во втором точка-многоточка.

Так же если на точке выполняющей роль базовой станции установлена лицензия level 3, то работа в режиме ap bridge невозможна. Ну или работать будет по принципу кто первый сел, тот и съел )) Хотя последнее не проверял, у меня нет точек с такой лицензией.

Выбор устройства для беспроводного моста

Собственно то, с чего следовало начать данную статью ))

Есть официальные рекомендации от MikroTik по выбору устройств в зависимости от расстояния и режима работы, остаётся только привести их здесь и следовать рекомендациям ))

Установка на месте

В моём конкретном случае антенны никак не юстировал, устанавливал на “глазок”. Небольшое расстояние плюс секторная антенна на 90 градусов позволяли это сделать. А вообще есть встроенная утилита для настройки направления антенны. Для её использования на базовой станции устанавливается Mode alignment only и на клиентской станции запускается утилита Align из меню настроек wlan.

Так как сам ею не пользовался, а переписывать чужое не в моих правилах, то и описание пока опущу. Как только воспользуюсь так сразу восполню данный пробел.

А пока просто приведу скриншот вкладки статус подключения.

Источники

  • https://xn—-7sba7aachdbqfnhtigrl.xn--j1amh/kak-nastroit-router-mikrotik-bazovaya-konfiguracziya/
  • https://blog.telecom-sales.ru/postroenie-i-nastrojka-prozrachnogo-besprovodnogo-mosta-na-primere-mikrotik-sxt/
  • https://14bytes.ru/nastrojka-mikrotik-bridge/
  • https://lantorg.com/article/nastrojka-mikrotik-dlya-soedineniya-tochka-tochka
  • https://WiFiGid.ru/mikrotik/wi-fi-most-mikrotik
  • https://grib69.ru/2020/06/28/mikrotik-nastrojka-besprovodnogo-mosta-tochka-tochka-p-t-p-i-tochka-mnogotochka-p-t-mp/

Понравилась статья? Поделиться с друзьями:
Переход на цифровое телевидение в России 2019
Добавить комментарий

;-) :| :x :twisted: :smile: :shock: :sad: :roll: :razz: :oops: :o :mrgreen: :lol: :idea: :grin: :evil: :cry: :cool: :arrow: :???: :?: :!: